Account Creation Outage

Incident Report for RentSpree

Resolved

The outage has been resolved. Thank you for your patience!
Posted Mar 03, 2026 - 07:40 PST

Investigating

We’re investigating an issue with account sign-up and password resets that are impacting all users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly. Thank you for your patience.

If you would like to be updated once the issues is resolved please use this link: https://share.hsforms.com/1OLctCsQ5QaClToI4MolKsw1swmx
Posted Mar 03, 2026 - 07:19 PST
This incident affected: Tenant screening & other features (Home Page).