Delays impacting Tenant Screening and Applications

Incident Report for RentSpree

Resolved

This incident has been resolved.
Posted Feb 15, 2026 - 07:03 PST

Identified

We’ve identified an issue with Tenant Screening and Applications that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly. Thank you for your patience.
Posted Feb 15, 2026 - 01:01 PST
This incident affected: Tenant screening & other features (Tenant Screening).