Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 18:00 PDT
Scheduled
TransUnion will perform system maintenance today, April 24th, from 7 p.m. to 9 p.m. Pacific Time. This may cause intermittent downtime while submitting or viewing reports. If you experience any issues, please try again once the maintenance has finished. Thank you!
Posted Apr 24, 2025 - 15:37 PDT
This scheduled maintenance affected: Tenant screening & other features (Tenant Screening).