This incident has been resolved and phone support is back to normal. Thank you for your patience!
Posted Apr 16, 2025 - 10:48 PDT
Monitoring
Our partners are aware of the outage and are working on a solution. Some calls are coming through, but may experience audio issues. We recommend emailing Support@rentspree.com during this outage. Thank you.
Posted Apr 16, 2025 - 09:39 PDT
Investigating
We’re investigating an issue with our phone support that is impacting all users. We’re working to fix the problem as quickly as we can. For immediate support, please email Support@rentspree.com. Thank you!