Delays impacting tenant screening and applications

Incident Report for RentSpree

Resolved

We’re back! Tenant Screening and Applications should be up and running normally. Thanks for bearing with us.
Posted Feb 26, 2026 - 13:28 PST

Investigating

We’re investigating an issue with Tenant Screening and Applications that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly. Thank you for your patience.

If you would like to be updated once the issue is resolved ,please use this link: https://share.hsforms.com/1OLctCsQ5QaClToI4MolKsw1swmx
Posted Feb 26, 2026 - 11:25 PST
This incident affected: Tenant screening & other features (Tenant Screening).