Tenant Screening - Major Outage
Incident Report for
RentSpree
Resolved
This incident has been resolved.
Posted
Dec
08
,
2025
-
07:49
PST
Investigating
We’re investigating an issue with tenant screening that affects all users who view and submit reports. We’re working to fix the problem as quickly as we can. We’ll share another update shortly. Thank you for your patience.
If you would like to be updated once the issue is resolved, please use this link:
https://share.hsforms.com/1OLctCsQ5QaClToI4MolKsw1swmx
Posted
Dec
07
,
2025
-
23:33
PST
This incident affected: Tenant screening & other features (Tenant Screening).
×
Subscribe to Incident
Subscribe to updates for
Tenant Screening - Major Outage
via . You'll receive .