Temporary Issue with Report Viewing in California

Incident Report for RentSpree

Resolved

This incident has been resolved, and all reports are available for users in California. If you were impacted by this incident, please refresh your page and try viewing reports again. Thank you for your patience!
Posted Jun 30, 2025 - 10:17 PDT

Investigating

Some users may be unable to view certain screening reports due to a technical issue with accepting the ICRAA form. We’re actively working on a fix. Thank you for your patience.

If you would like to be updated once the issues is resolved please use this link: https://share.hsforms.com/1OLctCsQ5QaClToI4MolKsw1swmx
Posted Jun 30, 2025 - 08:38 PDT
This incident affected: Tenant screening & other features (Tenant Screening).